ESXi 6.5 Disk Latency Sorunu

Abone Ol İçerikleri Kaçırma
tarafından 7 Ocak 2017 tarihinde VMware, VMware ESXi kategorisine yazıldı.

Merhaba,

ESXi 6.5 kullanıyorsanız sunucu üzerinde bulunan local disk’lerde performans problemleri yaşayabilirsiniz.

ESXi 6.5 yeni release olduğu için halen üzerinde çeşitli testler yapıyoruz. Yine bir test sırasında ESXi 6.5 yüklü bir sunucu üzerine standart bir ISO yükleme işlemi ortalama 20 dakikada tamamlandığını gördüm. Tabi aynı şekilde virtual machine içine OS kurulumunda da bariz bir yavaşlık vardı. Disk bazlı bir sorun olduğu anladım ve ESXTOP üzerinden datastore üzerindeki latency değerlerini incelemeye başladım. Sunucu ve datastore üzerinde hiç yük olmamasına rağmen datastore latency değerleri 1000ms ‘in üzerinde olduğunu gördüm. Bunu görünce ilk olarak aşağıda yazmış olduğum makale aklıma geldi. Ancak biraz daha detaylı bakınca yaşadığım sorunun aşağıdaki link ile ilgisi olmadığını farkettim.

ESXTOP – Yüksek değerlerin görülmesi

Bir virtual machine üzerine OS kurulumu geç bile olsa yapabildim. Bunun sonucunda yapmış olduğum testlerde virtual machine’in Read/Write ‘inin 10-20 MB’i geçmediğini gördüm. Halbuki kullanmış olduğum datastore SSD tabanlı bir datastore. SSD ile ortalama 400-450 MB değerlerini görmem gerekiyordu.

Konu ile ilgili ufak bir araştırma yaptığımda bu ESXi 6.5 üzerinde bulunan native driver’dan kaynaklı olduğunu gördüm. Bu sorunun çözümü için yapmanız gereken oldukça basit. AHCI driver’ini disable etmemiz gerekiyor.

Bunun için ilk olarak SSH’a bağlanıyoruz.

ahci-driver


[root@localhost:~] esxcli software vib list | grep ahci
sata-ahci 3.0-22vmw.650.0.0.4564106 VMW VMwareCertified 2016-11-16
vmw-ahci 1.0.0-32vmw.650.0.0.4564106 VMW VMwareCertified 2016-11-16

İlk olarak yüklü olan ahci driver’larını görüyoruz.


esxcli system module set —enabled=false —module=“vmw_ahci"

Yukarıdaki komutu çalıştırdığımızda artık ahci dirver’ları disable duruma gelmiş oluyor. Yukarıdaki komutu çalıştırdıktan sonra ESXi host’u reboot etmemiz gerekiyor. Eğer reboot etmezseniz çalıştırdığınız komut’un bir işlevini göremezsiniz.

Bu konu ile ilgili aşağıdaki KB’yi inceleyebilirsiniz.

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2044993

Umarım faydalı olmuştur.

İyi çalışmalar.

0 0 vote
Makaleyi Oylamayı Unutmayın !

Bu yazı blog üzerinde Tayfun DEĞER tarafından paylaşılmıştır. 2009 yılında açılan blog kısa zaman içerisinde büyük bir izleyici kitlesine sahip olmuştur. Tayfun DEĞER danışmanlık ve eğitimler vermektedir. vExpert 2013-2019, VCP4/5/6, VCP5-DT, VCP-Cloud ve MCSE sertifikalarına sahiptir.Twitter 'dan @tayfundeger veya RSS ile sitedeki değişiklikleri takip edebilirsiniz.

Subscribe
Bildir
guest
3 Yorum
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Konuk
Konuk

Tayfın bey,

Bu makaleniz için çok teşekkür ediyorum. Bir süredir bu problemle boğuşuyordum ve makaleniz sayesinde çözdüm.

Ahmet EREN
Ahmet EREN

Hocam selamlar,

Dediğiniz gibi ben de aynı komutları uyguladım fakat yavaşlık problemi devam ediyor.
Komutu SSH’ile yapıştırdığı vakit “>” şeklinde kalmaktadır.

Keyifli günler diliyorum.

Şükrü Koç
Şükrü Koç

Bir kaç saattir bu sorunla uğraşıyorum, daha yeni yeni bulaştım bu ESXi işlerine. Sayenizde çözdüm çok rahatladım valla.